Põhiline Pc Ja Mac Kas meilid on tõstutundlikud?

Kas meilid on tõstutundlikud?



Palju segadust on selles, kas e-posti aadressid on tõstutundlikud või mitte. Mõni ütleb, et on, samas kui teine ​​väidab, et ei ole. Niisiis, kellel on õigus? Selles artiklis uurime, kas e-posti aadressid on tõstutundlikud või vahetundlikud.

Kas meilid on tõstutundlikud?

Mis teeb e-posti aadressi?

E-posti aadress koosneb kolmest osast - kohalikust osast (tuntud ka kui kasutajanimi), märgist @ ja domeeni osast. Igal osal on oma roll ja selle suhtes kehtivad oma reeglistikud. Siin on kiire ülevaade.

Standardi kohaselt võib e-posti aadressi kohalik osa olla kuni 64 tähemärki pikk ja see võib koosneda piiratud tähemärkide kogumist. Nende hulka kuuluvad ladina suurtähed ja tähed, numbrid 0–9, punkt ja erimärgid. Erimärkide hulka kuulub: [[email protected] # $% ^ & * () _- + = [] {} ~. See on domeeni osaga ühendatud @ -märgiga.

Domeeni osa võib olla kuni 255 tähemärki pikk. See võib sisaldada ladina tähestiku tähti (nii väikseid kui ka väikeseid tähti), numbreid 0 kuni 9 ja sidekriipsu. Sidekriips ei saa domeeni osa alustada ega lõpetada.

Kasutada võib ka rahvusvahelisi sümboleid, ehkki sellest hiljem.

Kas see on tõstutundlik?

Õige vastus sellele küsimusele on nii jah kui ei. Vastavalt RFC 5321 , on e-posti aadressi kohalik osa tõstutundlik. See tähendab, et teoreetiliselt ei ole [meiliga kaitstud] sama mis [meiliga kaitstud]. Kuid e-posti teenuse pakkujatel on vabadus kohelda kohalikke osi nii väiketähtede kui ka suurtähtedeta.

Näiteks [email protected], [email protected] ja [email protected] on teoreetiliselt erinevad e-posti aadressid. On lihtne mõista, kuidas see võib tekitada probleeme ja vähendada kasutuskogemust, kui meiliserver valis kohalike osade käsitlemise väiketähtedega. Seetõttu käsitlevad paljud teenusepakkujad e-posti aadressi kohalikku suurt ja väiketähti.

kuidas paljastada helistaja ID

Mis puudutab domeeni osa, RFC 1035 sätestab, et see on alati tõstutundetu. See tähendab, et saate selle kirjutada väiketähtede, suurtähtede või nende kahe kombinatsiooniga ning teie e-posti aadress jõuab samale aadressile. Praktilises kasutuses on [email protected], [email protected] ja [email protected] sama e-posti aadress.

Praktikas

Ehkki e-posti aadressid on tõstutundlikud ainult osaliselt, on üldiselt ohutu mõelda neile suurtähteta. Kõik suuremad teenusepakkujad, nagu Gmail, Yahoo Mail, Hotmail jt, käsitlevad e-posti aadresside kohalikke osi väiketähtede vahet tundmatuna. Sellest hoolimata peaksite kontrollima selle e-posti teenuse pakkuja reegleid, kellega soovite e-kirja luua.

Eelmises punktis öeldes soovitab ülalnimetatud RFC 5321 luua uued e-posti aadressid ainult väikeste tähtedega, et vältida võimalikke segadusi ja kohaletoimetamise probleeme.

Teisest küljest, kui teie sõbral või kolleegil on e-posti aadress koos väiketähtede ja väiketähtedega, on soovitatav see kirjutada sellisena, nagu talle e-kirja saadate. Vastasel juhul võib e-posti mitte kätte toimetada. Kuid see ei ole probleem suuremate e-posti pakkujate nagu Gmail, Yahoo Mail, Hotmail jt.

Lisaks on Gmail kasutajakonto tuvastamisel tundetu ka e-kirja kohalikus osas leiduvate punktide suhtes. See tähendab, et kui [meiliga kaitstud] konto on olemas, ei saa te [e-posti aadressi kaitstud] ega [meiliga kaitstud] registreerida

Rahvusvahelistumine

Algselt sai e-posti aadresse registreerida ainult ladina tähestiku tähtede, numbrite ja piiratud hulga spetsiaalsete ASCII tähemärkide abil. Siiski IETF (Internet Engineering Task Force) on hiljem välja töötanud reeglid ja standardid rahvusvaheliste märkide kaasamiseks.

RFC6530 oli esimene, kes hõlmas ja reguleeris rahvusvaheliste tähemärkide kasutamist. RFC6531 laiendatud reeglitele ja standarditele. Seejärel ajakohastati reegleid ja standardeid läbi RFC6532 ja RFC6533 .

Nüüd saate e-posti aadressi registreerida mitmesuguste tähestike, märkide ja skriptide abil. Mõned kõige enam kasutatavad on ladina tähed diakriitikutega, kreeka tähestik, hiina traditsioonilised tähemärgid, jaapani tähemärgid (hiragana, katakana ja kanji), kirillitsa tähestik, mitmed India skriptid, aga ka mitmed teised.

Rahvusvaheliste e-posti aadresside lisamine ja ühilduvus nendega on teenusepakkujalt erinev. Isegi mõned suurimad pakkujad ei ühildu täielikult rahvusvaheliste aadressidega. Näiteks lubab Google teil saata e-posti rahvusvahelisele aadressile, kuid see ei luba teil seda luua. Outlook 2016 on sarnase funktsionaalsusega.

Järeldus

Erinevalt domeeninime osast on e-posti aadressi kohalik osa tõstutundlik. Sellest hoolimata otsustavad paljud e-posti teenuse pakkujad praktilistel põhjustel ignoreerida kohaliku osa väiketähtede tundlikkust ja julgustavad inimesi looma ainult väikeste tähtedega kirju.

Huvitavad Artiklid

Toimetaja Valik

Kuidas muuta Google'i koduhäire heli
Kuidas muuta Google'i koduhäire heli
Äratuskellad on minevik. Tänapäeval on palju ägedaid nutikaid äratuskellasid. Näiteks, kas teadsite, et saate oma Google Home'i kasutada häirena? Reeglina võivad piiksuvad häired olla väga
Kuidas eemaldada tulekahju rakendusest Alexa
Kuidas eemaldada tulekahju rakendusest Alexa
Esiteks on Amazon Firestick üks populaarsemaid Alexa seadmeid seal. See on Bluetoothi ​​kaugjuhtimispult, mis on varustatud häältoega ja klanitud, minimalistliku disainiga. Nagu iga teine ​​Alexa seade, on ka teie Firestick
Mis on HKEY_LOCAL_MACHINE?
Mis on HKEY_LOCAL_MACHINE?
HKEY_LOCAL_MACHINE, sageli lühendatud HKLM-ks, on registri taru, mis sisaldab enamikku Windowsi konfiguratsiooniandmetest.
Kuidas aksolotleid Minecraftis taltsutada
Kuidas aksolotleid Minecraftis taltsutada
Kui teate, kuidas aksolotleid taltsutada, saate neid aretada ja teha neist oma liitlased. Siit saate teada, mida aksolotlid söövad ja kust neid Minecraftis leida.
Gmaili konto lisamine Outlooki
Gmaili konto lisamine Outlooki
Nagu võite teada, on Outlook ühilduv kõigi suuremate e-posti teenuse pakkujatega. Kuna enamikul inimestel on vähemalt üks Gmaili konto, näitame teile, kuidas saate oma oma Outlooki lisada. Me selgitame protsessi
Hosts-faili haldamine Windows 10-s
Hosts-faili haldamine Windows 10-s
https://youtu.be/abKGhz_qoMw Hostifail on arvutifail, mida opsüsteem kasutab hostinimede IP-aadressidele kaardistamiseks. See on lihttekstifail, mida tavapäraselt nimetatakse hostiks. Windows 10-s pole see erinev. Vikipeedia määratleb
Kuidas saada Robloxis rohkem restoranikliente
Kuidas saada Robloxis rohkem restoranikliente
Minu restoran on Robloxi üks populaarseimaid ajaviiteid. Kasutajad võistlevad kõige kasumlikumate restoranide ehitamise eest avalikele või VIP-serveritele. Kuigi see on lõbus mäng, võib selles liikumine olla keeruline